Managing duplicate invoice numbers

Possible Error Message

Invoice validation failed: A duplicate has been found for invoice number.

This means an invoice with the same invoice number already exists on the supplier's account in IRIS Financials. If this is the case the document Status remains at Post in Progress.

You can also ask your Administrator to check the IRIS Invoice Matcher error log on the server. Refer to Accessing the IRIS Invoice Matcher Error Log for more information.

Cause

IRIS Invoice Matcher requires a user to validate if a duplicate invoice number is recognised. A user has verified the warning, but duplicate invoice numbers do not post to IRIS Financials.

Resolution

  1. Check the supplier account to see if the invoice is a duplicate. If it is a genuine duplicate - delete the invoice in IRIS Invoice Matcher.

  2. If it is not a duplicate - you can manually change the invoice number in IRIS Invoice Matcher and verify.

  3. If the invoice is not a duplicate, speak to the supplier and ask them to specify a unique invoice number on future invoices. This will help the automatic matching in future.